aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120-2.6/patches/005-adm5120_usb.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120-2.6/patches/005-adm5120_usb.patch')
-rw-r--r--target/linux/adm5120-2.6/patches/005-adm5120_usb.patch58
1 files changed, 0 insertions, 58 deletions
diff --git a/target/linux/adm5120-2.6/patches/005-adm5120_usb.patch b/target/linux/adm5120-2.6/patches/005-adm5120_usb.patch
deleted file mode 100644
index f48b0f96c3..0000000000
--- a/target/linux/adm5120-2.6/patches/005-adm5120_usb.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-Index: linux-2.6.21.1/drivers/usb/core/hub.c
-===================================================================
---- linux-2.6.21.1.orig/drivers/usb/core/hub.c
-+++ linux-2.6.21.1/drivers/usb/core/hub.c
-@@ -2227,6 +2227,8 @@ hub_port_init (struct usb_hub *hub, stru
- USB_DT_DEVICE << 8, 0,
- buf, GET_DESCRIPTOR_BUFSIZE,
- (i ? USB_CTRL_GET_TIMEOUT : 1000));
-+printk(KERN_CRIT "usb_control_msg: %d %d %d (%d)\n", r, buf->bMaxPacketSize0,
-+buf->bDescriptorType, USB_DT_DEVICE);
- switch (buf->bMaxPacketSize0) {
- case 8: case 16: case 32: case 64: case 255:
- if (buf->bDescriptorType ==
-Index: linux-2.6.21.1/drivers/usb/host/Kconfig
-===================================================================
---- linux-2.6.21.1.orig/drivers/usb/host/Kconfig
-+++ linux-2.6.21.1/drivers/usb/host/Kconfig
-@@ -224,3 +224,6 @@ config USB_SL811_CS
- To compile this driver as a module, choose M here: the
- module will be called "sl811_cs".
-
-+config USB_ADM5120_HCD
-+ tristate "ADM5120 HCD support"
-+ depends on USB && MIPS_ADM5120
-Index: linux-2.6.21.1/drivers/usb/host/Makefile
-===================================================================
---- linux-2.6.21.1.orig/drivers/usb/host/Makefile
-+++ linux-2.6.21.1/drivers/usb/host/Makefile
-@@ -16,3 +16,4 @@ obj-$(CONFIG_USB_SL811_HCD) += sl811-hcd
- obj-$(CONFIG_USB_SL811_CS) += sl811_cs.o
- obj-$(CONFIG_USB_U132_HCD) += u132-hcd.o
- obj-$(CONFIG_ETRAX_ARCH_V10) += hc_crisv10.o
-+obj-$(CONFIG_USB_ADM5120_HCD) += adm5120-hcd.o
-Index: linux-2.6.21.1/drivers/usb/Kconfig
-===================================================================
---- linux-2.6.21.1.orig/drivers/usb/Kconfig
-+++ linux-2.6.21.1/drivers/usb/Kconfig
-@@ -91,8 +91,6 @@ source "drivers/usb/image/Kconfig"
-
- source "drivers/usb/net/Kconfig"
-
--source "drivers/usb/mon/Kconfig"
--
- comment "USB port drivers"
- depends on USB
-
-Index: linux-2.6.21.1/drivers/usb/Makefile
-===================================================================
---- linux-2.6.21.1.orig/drivers/usb/Makefile
-+++ linux-2.6.21.1/drivers/usb/Makefile
-@@ -17,6 +17,7 @@ obj-$(CONFIG_USB_SL811_HCD) += host/
- obj-$(CONFIG_USB_U132_HCD) += host/
- obj-$(CONFIG_ETRAX_USB_HOST) += host/
- obj-$(CONFIG_USB_OHCI_AT91) += host/
-+obj-$(CONFIG_USB_ADM5120_HCD) += host/
-
- obj-$(CONFIG_USB_ACM) += class/
- obj-$(CONFIG_USB_PRINTER) += class/