aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/fs.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 536e28b4c6..70387fd99d 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -203,6 +203,7 @@ $(eval $(call KernelPackage,fs-minix))
define KernelPackage/fs-msdos
SUBMENU:=$(FS_MENU)
TITLE:=MSDOS filesystem support
+ DEPENDS:=+kmod-fs-vfat
KCONFIG:=CONFIG_MSDOS_FS
FILES:=$(LINUX_DIR)/fs/fat/msdos.ko
AUTOLOAD:=$(call AutoLoad,40,msdos)
@@ -360,7 +361,7 @@ define KernelPackage/fs-xfs
SUBMENU:=$(FS_MENU)
TITLE:=XFS filesystem support
KCONFIG:=CONFIG_XFS_FS
- DEPENDS:= +kmod-fs-exportfs @!avr32
+ DEPENDS:= +kmod-fs-exportfs +kmod-lib-crc32c @!avr32
FILES:=$(LINUX_DIR)/fs/xfs/xfs.ko
AUTOLOAD:=$(call AutoLoad,30,xfs,1)
endef