aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/igmpproxy/Makefile2
-rw-r--r--package/network/services/lldpd/Makefile2
-rw-r--r--package/network/services/samba36/Makefile2
-rw-r--r--package/network/utils/iproute2/Makefile6
-rw-r--r--package/network/utils/iputils/Makefile2
6 files changed, 7 insertions, 9 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index d1bbab86e7..eeba02802a 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -89,7 +89,7 @@ ifneq ($(LOCAL_TYPE),hostapd)
CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
endif
-ifdef CONFIG_USE_EGLIBC
+ifdef CONFIG_USE_GLIBC
TARGET_LDFLAGS += -lrt
TARGET_LDFLAGS_C += -lrt
endif
diff --git a/package/network/services/igmpproxy/Makefile b/package/network/services/igmpproxy/Makefile
index 33ed014040..03ad25819b 100644
--- a/package/network/services/igmpproxy/Makefile
+++ b/package/network/services/igmpproxy/Makefile
@@ -25,7 +25,7 @@ define Package/igmpproxy
SECTION:=net
CATEGORY:=Network
SUBMENU:=Routing and Redirection
- DEPENDS:=+USE_EGLIBC:librt
+ DEPENDS:=+USE_GLIBC:librt
TITLE:=Multicast Routing Daemon
URL:=http://sourceforge.net/projects/igmpproxy
endef
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 6f97f45e65..f038a340ac 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -31,7 +31,7 @@ define Package/lldpd
SUBMENU:=Routing and Redirection
TITLE:=Link Layer Discovery Protocol daemon
URL:=https://github.com/vincentbernat/lldpd/wiki
- DEPENDS:=+libevent2 +USE_EGLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
+ DEPENDS:=+libevent2 +USE_GLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
USERID:=lldp=121:lldp=129
MENU:=1
endef
diff --git a/package/network/services/samba36/Makefile b/package/network/services/samba36/Makefile
index d4c96d3854..70dfb2b16f 100644
--- a/package/network/services/samba36/Makefile
+++ b/package/network/services/samba36/Makefile
@@ -35,7 +35,7 @@ define Package/samba36-server
CATEGORY:=Network
TITLE:=Samba 3.6 SMB/CIFS server
URL:=http://www.samba.org/
- DEPENDS:=+USE_EGLIBC:librt
+ DEPENDS:=+USE_GLIBC:librt
endef
define Package/samba36-client
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 56d2897e2a..a2dae6d61b 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -82,10 +82,8 @@ define Build/Configure
> $(PKG_BUILD_DIR)/include/SNAPSHOT.h
endef
-ifdef CONFIG_USE_EGLIBC
- ifndef CONFIG_EGLIBC_VERSION_2_13
- TARGET_CFLAGS += -DHAVE_SETNS
- endif
+ifdef CONFIG_USE_GLIBC
+ TARGET_CFLAGS += -DHAVE_SETNS
endif
ifdef CONFIG_USE_MUSL
TARGET_CFLAGS += -DHAVE_SETNS
diff --git a/package/network/utils/iputils/Makefile b/package/network/utils/iputils/Makefile
index 1dc993cb81..8d7b84d6b5 100644
--- a/package/network/utils/iputils/Makefile
+++ b/package/network/utils/iputils/Makefile
@@ -68,7 +68,7 @@ endef
define Package/iputils-ping6
$(call Package/iputils/Default)
TITLE:=iputils - ping6
- DEPENDS+= @IPV6 +USE_EGLIBC:libopenssl
+ DEPENDS+= @IPV6 +USE_GLIBC:libopenssl
endef
define Package/iputils-ping6/description