aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils')
-rw-r--r--package/network/utils/arptables/Makefile26
-rw-r--r--package/network/utils/arptables/patches/100-always_optimize.patch19
-rw-r--r--package/network/utils/arptables/patches/200-musl_fixes.patch31
-rw-r--r--package/network/utils/conntrack-tools/Makefile12
-rw-r--r--package/network/utils/iptables/patches/500-add-xt_id-match.patch69
-rw-r--r--package/network/utils/nftables/Makefile16
-rw-r--r--package/network/utils/nftables/patches/100-disable-doc-generation.patch8
7 files changed, 21 insertions, 160 deletions
diff --git a/package/network/utils/arptables/Makefile b/package/network/utils/arptables/Makefile
index 62681dcd59..bae843a4ff 100644
--- a/package/network/utils/arptables/Makefile
+++ b/package/network/utils/arptables/Makefile
@@ -1,4 +1,4 @@
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,15 +7,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=arptables
-PKG_VERSION:=0.0.4
+PKG_VERSION:=2015-05-20
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/ebtables
-PKG_MD5SUM:=c2e99c3aa9d78c9dfa30710ca3168182
-PKG_LICENSE:=GPL-2.0
+PKG_SOURCE_URL:=git://git.netfilter.org/arptables
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=f4ab8f63f11a72f14687a6646d04ae1bae3fa45f
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
+PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
@@ -25,15 +26,12 @@ define Package/arptables
SUBMENU:=Firewall
TITLE:=ARP firewalling software
DEPENDS:=+kmod-arptables
- URL:=http://ebtables.sourceforge.net
+ URL:=https://git.netfilter.org/arptables/
endef
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- COPT_FLAGS="$(TARGET_CFLAGS)" \
- KERNEL_DIR="./include/linux"
-endef
+MAKE_FLAGS += \
+ COPT_FLAGS="$(TARGET_CFLAGS) -D__OPTIMIZE__=1" \
+ KERNEL_DIR="$(LINUX_DIR)"
define Package/arptables/install
$(INSTALL_DIR) $(1)/usr/sbin
diff --git a/package/network/utils/arptables/patches/100-always_optimize.patch b/package/network/utils/arptables/patches/100-always_optimize.patch
deleted file mode 100644
index b120eb783a..0000000000
--- a/package/network/utils/arptables/patches/100-always_optimize.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: arptables-v0.0.3-4/libarptc/libarptc_incl.c
-===================================================================
---- arptables-v0.0.3-4.orig/libarptc/libarptc_incl.c 2010-03-08 16:49:28.000000000 +0100
-+++ arptables-v0.0.3-4/libarptc/libarptc_incl.c 2012-08-14 12:10:29.527945144 +0200
-@@ -11,14 +11,6 @@
- /* (C)1999 Paul ``Rusty'' Russell - Placed under the GNU GPL (See
- COPYING for details). */
-
--#ifndef __OPTIMIZE__
--STRUCT_ENTRY_TARGET *
--GET_TARGET(STRUCT_ENTRY *e)
--{
-- return (void *)e + e->target_offset;
--}
--#endif
--
- static int sockfd = -1;
- static void *arptc_fn = NULL;
-
diff --git a/package/network/utils/arptables/patches/200-musl_fixes.patch b/package/network/utils/arptables/patches/200-musl_fixes.patch
deleted file mode 100644
index 3a4ba3fb03..0000000000
--- a/package/network/utils/arptables/patches/200-musl_fixes.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/include/arptables.h
-+++ b/include/arptables.h
-@@ -1,6 +1,7 @@
- #ifndef _ARPTABLES_USER_H
- #define _ARPTABLES_USER_H
-
-+#include <sys/types.h>
- #include "arptables_common.h"
- #include "libarptc/libarptc.h"
-
---- a/arptables.c
-+++ b/arptables.c
-@@ -43,6 +43,7 @@
- #include <arptables.h>
- #include <fcntl.h>
- #include <sys/wait.h>
-+#include <net/ethernet.h>
-
- #ifndef TRUE
- #define TRUE 1
---- a/include/libarptc/arpt_kernel_headers.h
-+++ b/include/libarptc/arpt_kernel_headers.h
-@@ -5,7 +5,7 @@
-
- #include <limits.h>
-
--#if defined(__GLIBC__) && __GLIBC__ == 2
-+#if 1
- #include <netinet/ip.h>
- #include <netinet/in.h>
- #include <netinet/ip_icmp.h>
diff --git a/package/network/utils/conntrack-tools/Makefile b/package/network/utils/conntrack-tools/Makefile
index fd13e222a9..868f9604de 100644
--- a/package/network/utils/conntrack-tools/Makefile
+++ b/package/network/utils/conntrack-tools/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=conntrack-tools
-PKG_VERSION:=1.4.3
+PKG_VERSION:=1.4.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -16,22 +16,16 @@ PKG_SOURCE_URL:= \
http://www.netfilter.org/projects/conntrack-tools/files \
ftp://ftp.netfilter.org/pub/conntrack-tools \
http://mirrors.evolva.ro/netfilter.org/conntrack-tools
-PKG_MD5SUM:=966a5d8f846ddf5304bcd12685c0707f
+PKG_MD5SUM:=acd9e0b27cf16ae3092ba900e4d7560e
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=GPL-2.0
-PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
-TAR_OPTIONS += --exclude='*.rej'
-
PKG_BUILD_DEPENDS:=librpc
include $(INCLUDE_DIR)/package.mk
-TARGET_CFLAGS += -D_GNU_SOURCE=1
-
define Package/conntrack-tools/default
SECTION:=net
CATEGORY:=Network
diff --git a/package/network/utils/iptables/patches/500-add-xt_id-match.patch b/package/network/utils/iptables/patches/500-add-xt_id-match.patch
deleted file mode 100644
index 0964f0175f..0000000000
--- a/package/network/utils/iptables/patches/500-add-xt_id-match.patch
+++ /dev/null
@@ -1,69 +0,0 @@
---- /dev/null
-+++ b/extensions/libxt_id.c
-@@ -0,0 +1,55 @@
-+/* Shared library add-on to iptables to add id match support. */
-+
-+#include <stdio.h>
-+#include <xtables.h>
-+#include <linux/netfilter/xt_id.h>
-+
-+enum {
-+ O_ID = 0,
-+};
-+
-+static const struct xt_option_entry id_opts[] = {
-+ {
-+ .name = "id",
-+ .id = O_ID,
-+ .type = XTTYPE_UINT32,
-+ .flags = XTOPT_MAND | XTOPT_PUT,
-+ XTOPT_POINTER(struct xt_id_info, id)
-+ },
-+ XTOPT_TABLEEND,
-+};
-+
-+static void
-+id_print(const void *ip, const struct xt_entry_match *match, int numeric)
-+{
-+ struct xt_id_info *idinfo = (void *)match->data;
-+
-+ printf(" ID:%08lx", idinfo->id);
-+}
-+
-+
-+/* Saves the union ipt_matchinfo in parsable form to stdout. */
-+static void
-+id_save(const void *ip, const struct xt_entry_match *match)
-+{
-+ struct xt_id_info *idinfo = (void *)match->data;
-+
-+ printf(" --id 0x%lx", idinfo->id);
-+}
-+
-+static struct xtables_match id_match = {
-+ .family = NFPROTO_UNSPEC,
-+ .name = "id",
-+ .version = XTABLES_VERSION,
-+ .size = XT_ALIGN(sizeof(struct xt_id_info)),
-+ .userspacesize = XT_ALIGN(sizeof(struct xt_id_info)),
-+ .print = id_print,
-+ .save = id_save,
-+ .x6_parse = xtables_option_parse,
-+ .x6_options = id_opts,
-+};
-+
-+void _init(void)
-+{
-+ xtables_register_match(&id_match);
-+}
---- /dev/null
-+++ b/include/linux/netfilter/xt_id.h
-@@ -0,0 +1,8 @@
-+#ifndef _XT_ID_H
-+#define _XT_ID_H
-+
-+struct xt_id_info {
-+ __u32 id;
-+};
-+
-+#endif /* XT_ID_H */
diff --git a/package/network/utils/nftables/Makefile b/package/network/utils/nftables/Makefile
index 96db6fff70..b98e9fb8b5 100644
--- a/package/network/utils/nftables/Makefile
+++ b/package/network/utils/nftables/Makefile
@@ -1,4 +1,4 @@
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,18 +7,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nftables
-PKG_VERSION:=0.4+2015-04-09
+PKG_VERSION:=0.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=git://git.netfilter.org/nftables
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=3ed296118a065caff5600e60d4f7ef18e137f9a0
-PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
-PKG_LICENSE:=GPL-2.0
+PKG_SOURCE_URL:=ftp://ftp.netfilter.org/pub/nftables
+PKG_MD5SUM:=fd320e35fdf14b7be795492189b13dae
-PKG_FIXUP:=autoreconf
+PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
@@ -31,7 +27,7 @@ define Package/nftables
CATEGORY:=Network
SUBMENU:=Firewall
TITLE:=nftables packet filtering userspace utility
- DEPENDS:=+kmod-nft-core +kmod-nft-nat +libnftnl
+ DEPENDS:=+kmod-nft-core +kmod-nft-nat +libnftnl +libmnl
URL:=http://netfilter.org/projects/nftables/
endef
diff --git a/package/network/utils/nftables/patches/100-disable-doc-generation.patch b/package/network/utils/nftables/patches/100-disable-doc-generation.patch
deleted file mode 100644
index bcbffe25c7..0000000000
--- a/package/network/utils/nftables/patches/100-disable-doc-generation.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -2,5 +2,4 @@ ACLOCAL_AMFLAGS = -I m4
-
- SUBDIRS = src \
- include \
-- doc \
- files