aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi/patches/100-kernel_cflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/madwifi/patches/100-kernel_cflags.patch')
-rw-r--r--package/madwifi/patches/100-kernel_cflags.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/madwifi/patches/100-kernel_cflags.patch b/package/madwifi/patches/100-kernel_cflags.patch
index 7eb65c5fc9..ef886bf36d 100644
--- a/package/madwifi/patches/100-kernel_cflags.patch
+++ b/package/madwifi/patches/100-kernel_cflags.patch
@@ -18,6 +18,16 @@ diff -urN madwifi-ng-refcount-r2313-20070505.old/hal/public/mips-le-elf.inc madw
-COPTS+= -G 0 -EL -mno-abicalls -fno-pic -mips2 -Wa,--trap \
+COPTS+= -G 0 -mno-abicalls -fno-pic -mips32 -Wa,--trap \
-fno-strict-aliasing -fno-common -fomit-frame-pointer -mlong-calls
+diff -ur madwifi.old/hal/public/xscale-be-elf.inc madwifi.dev/hal/public/xscale-be-elf.inc
+--- madwifi.old/hal/public/xscale-be-elf.inc 2006-09-14 08:21:22.000000000 +0200
++++ madwifi.dev/hal/public/xscale-be-elf.inc 2007-05-13 19:30:47.106546544 +0200
+@@ -77,5 +77,5 @@
+
+ LDOPTS= -EB
+ COPTS+= -DAH_BYTE_ORDER=AH_BIG_ENDIAN
+-COPTS+= -march=armv4 -mbig-endian -fno-strict-aliasing -fno-common -mapcs-32 \
++COPTS+= -march=armv5te -mbig-endian -fno-strict-aliasing -fno-common \
+ -mtune=xscale -mshort-load-bytes
diff -urN madwifi-ng-refcount-r2313-20070505.old/Makefile madwifi-ng-refcount-r2313-20070505.dev/Makefile
--- madwifi-ng-refcount-r2313-20070505.old/Makefile 2007-03-08 20:59:06.000000000 +0100
+++ madwifi-ng-refcount-r2313-20070505.dev/Makefile 2007-05-13 18:17:54.963213360 +0200
@@ -30,3 +40,4 @@ diff -urN madwifi-ng-refcount-r2313-20070505.old/Makefile madwifi-ng-refcount-r2
ifdef LINUX24
for i in $(DIRS_MODULES); do \
$(MAKE) -C $$i || exit 1; \
+