aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/virtual.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/virtual.mk b/package/kernel/linux/modules/virtual.mk
index e1bbe3f439..3a1fe006fa 100644
--- a/package/kernel/linux/modules/virtual.mk
+++ b/package/kernel/linux/modules/virtual.mk
@@ -142,8 +142,9 @@ $(eval $(call KernelPackage,xen-fbdev))
define KernelPackage/xen-kbddev
SUBMENU:=$(VIRTUAL_MENU)
TITLE:=Xen virtual keyboard and mouse
- DEPENDS:=@TARGET_x86_xen_domu
- KCONFIG:=CONFIG_XEN_KBDDEV_FRONTEND
+ DEPENDS:=@TARGET_x86_xen_domu +kmod-input-core
+ KCONFIG:=CONFIG_INPUT_MISC=y \
+ CONFIG_INPUT_XEN_KBDDEV_FRONTEND
FILES:=$(LINUX_DIR)/drivers/input/xen-kbdfront.ko
AUTOLOAD:=$(call AutoLoad,08,xen-kbdfront)
endef