aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/crypto.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index ad1fe4e723..d17f1e1ae3 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -12,7 +12,6 @@ CRYPTO_MODULES = \
BLKCIPHER2=crypto_blkcipher
CRYPTOMGR_MODULES = \
- AEAD2=aead \
MANAGER2=cryptomgr
crypto_confvar=CONFIG_CRYPTO_$(word 1,$(subst =,$(space),$(1)))
@@ -65,9 +64,8 @@ $(eval $(call KernelPackage,crypto-hash))
define KernelPackage/crypto-manager
TITLE:=CryptoAPI algorithm manager
- DEPENDS:=+kmod-crypto-hash +kmod-crypto-pcompress
+ DEPENDS:=+kmod-crypto-aead +kmod-crypto-hash +kmod-crypto-pcompress
KCONFIG:= \
- CONFIG_CRYPTO_AEAD \
CONFIG_CRYPTO_MANAGER \
$(foreach mod,$(CRYPTOMGR_MODULES),$(call crypto_confvar,$(mod)))
FILES:=$(foreach mod,$(CRYPTOMGR_MODULES),$(call crypto_file,$(mod)))