aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/fs.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 60933f2192..867117fab0 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -225,9 +225,14 @@ define KernelPackage/fs-nfs
CONFIG_NFS_FS \
CONFIG_NFS_USE_LEGACY_DNS=n \
CONFIG_NFS_USE_NEW_IDMAPPER=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
FILES:= \
$(LINUX_DIR)/fs/nfs/nfs.ko \
$(LINUX_DIR)/fs/nfs/nfsv3.ko
+else
+ FILES:= \
+ $(LINUX_DIR)/fs/nfs/nfs.ko
+endif
AUTOLOAD:=$(call AutoLoad,40,nfs nfsv3)
endef