aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index ef0fbce09a..301460e416 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1024,3 +1024,51 @@ define KernelPackage/echo/description
endef
$(eval $(call KernelPackage,echo))
+
+
+define KernelPackage/bmp085
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=BMP085/BMP18x pressure sensor
+ DEPENDS:= +kmod-regmap
+ KCONFIG:= CONFIG_BMP085
+ FILES:= $(LINUX_DIR)/drivers/misc/bmp085.ko
+endef
+
+define KernelPackage/bmp085/description
+ This driver adds support for Bosch Sensortec's digital pressure
+ sensors BMP085 and BMP18x.
+endef
+
+$(eval $(call KernelPackage,bmp085))
+
+
+define KernelPackage/bmp085-i2c
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=BMP085/BMP18x pressure sensor I2C
+ DEPENDS:= +kmod-bmp085
+ KCONFIG:= CONFIG_BMP085_I2C
+ FILES:= $(LINUX_DIR)/drivers/misc/bmp085-i2c.ko
+ AUTOLOAD:=$(call AutoProbe,bmp085-i2c)
+endef
+define KernelPackage/bmp085-i2c/description
+ This driver adds support for Bosch Sensortec's digital pressure
+ sensor connected via I2C.
+endef
+
+$(eval $(call KernelPackage,bmp085-i2c))
+
+
+define KernelPackage/bmp085-spi
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=BMP085/BMP18x pressure sensor SPI
+ DEPENDS:= +kmod-bmp085
+ KCONFIG:= CONFIG_BMP085_SPI
+ FILES:= $(LINUX_DIR)/drivers/misc/bmp085-spi.ko
+ AUTOLOAD:=$(call AutoProbe,bm085-spi)
+endef
+define KernelPackage/bmp085-spi/description
+ This driver adds support for Bosch Sensortec's digital pressure
+ sensor connected via SPI.
+endef
+
+$(eval $(call KernelPackage,bmp085-spi))