aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 9dd47344de..7831f701a2 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -258,3 +258,17 @@ define KernelPacakge/hwmon-gsc/description
endef
$(eval $(call KernelPackage,hwmon-gsc))
+
+define KernelPackage/hwmon-tmp421
+ TITLE:=TI TMP421 and compatible monitoring support
+ KCONFIG:=CONFIG_SENSORS_TMP421
+ FILES:=$(LINUX_DIR)/drivers/hwmon/tmp421.ko
+ AUTOLOAD:=$(call AutoLoad,60,tmp421)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPacakge/hwmon-tmp421/description
+ Kernel module for the Texas Instruments TMP421 and compatible chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-tmp421))