aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-06-17 15:03:05 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-06-17 15:03:05 +0000
commitf71d455502323e4bce3df847fb5481adcf5602c7 (patch)
tree86bc312aa6e16cccfeb0fba06d4fe747234e0e68 /package/kernel/linux/modules/hwmon.mk
parente5f83a5da48778dc7c9c34dd9b8683161925a7c8 (diff)
downloadmaster-187ad058-f71d455502323e4bce3df847fb5481adcf5602c7.tar.gz
master-187ad058-f71d455502323e4bce3df847fb5481adcf5602c7.tar.bz2
master-187ad058-f71d455502323e4bce3df847fb5481adcf5602c7.zip
[kernel]: package the TI TMP421 driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41231 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 9dd47344de..7831f701a2 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -258,3 +258,17 @@ define KernelPacakge/hwmon-gsc/description
endef
$(eval $(call KernelPackage,hwmon-gsc))
+
+define KernelPackage/hwmon-tmp421
+ TITLE:=TI TMP421 and compatible monitoring support
+ KCONFIG:=CONFIG_SENSORS_TMP421
+ FILES:=$(LINUX_DIR)/drivers/hwmon/tmp421.ko
+ AUTOLOAD:=$(call AutoLoad,60,tmp421)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPacakge/hwmon-tmp421/description
+ Kernel module for the Texas Instruments TMP421 and compatible chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-tmp421))