aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index cc62f2cc27..f11ebd931a 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -123,12 +123,11 @@ $(eval $(call KernelPackage,crypto-rng))
define KernelPackage/crypto-iv
TITLE:=CryptoAPI initialization vectors
DEPENDS:=+kmod-crypto-manager +kmod-crypto-rng +kmod-crypto-wq
- KCONFIG:= CONFIG_CRYPTO_BLKCIPHER2 CONFIG_CRYPTO_ECHAINIV
+ KCONFIG:= CONFIG_CRYPTO_BLKCIPHER2
FILES:= \
- $(LINUX_DIR)/crypto/eseqiv.ko \
- $(LINUX_DIR)/crypto/chainiv.ko \
- $(LINUX_DIR)/crypto/echainiv.ko@ge4.3
- AUTOLOAD:=$(call AutoLoad,10,eseqiv chainiv echainiv@ge4.3)
+ $(LINUX_DIR)/crypto/eseqiv.ko@lt4.8 \
+ $(LINUX_DIR)/crypto/chainiv.ko@lt4.8
+ AUTOLOAD:=$(call AutoLoad,10,eseqiv chainiv)
$(call AddDepends/crypto)
endef