aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 7c710531cc..99fb5a0e25 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -177,6 +177,24 @@ endef
$(eval $(call KernelPackage,crypto-hw-padlock))
+define KernelPackage/crypto-hw-ccp
+ TITLE:=AMD Cryptographic Coprocessor
+ DEPENDS:=+kmod-crypto-authenc +kmod-crypto-hash +kmod-crypto-manager +kmod-random-core
+ KCONFIG:= \
+ CONFIG_CRYPTO_HW=y \
+ CONFIG_CRYPTO_DEV_CCP=y \
+ CONFIG_CRYPTO_DEV_CCP_CRYPTO \
+ CONFIG_CRYPTO_DEV_CCP_DD
+ FILES:= \
+ $(LINUX_DIR)/drivers/crypto/ccp/ccp.ko \
+ $(LINUX_DIR)/drivers/crypto/ccp/ccp-crypto.ko
+ AUTOLOAD:=$(call AutoLoad,09,ccp ccp-crypto)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ccp))
+
+
define KernelPackage/crypto-hw-geode
TITLE:=AMD Geode hardware crypto module
DEPENDS:=+kmod-crypto-manager