aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk20
1 files changed, 19 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 4f9517f4f9..0600361a61 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -29,6 +29,7 @@ define KernelPackage/crypto-core
FILES:=$(foreach mod,$(CRYPTO_MODULES),$(call crypto_file,$(mod)))
AUTOLOAD:=$(call AutoLoad,01,$(foreach mod,$(CRYPTO_MODULES),$(call crypto_name,$(mod))),1)
endef
+
$(eval $(call KernelPackage,crypto-core))
@@ -44,8 +45,10 @@ define KernelPackage/crypto-hash
AUTOLOAD:=$(call AutoLoad,02,crypto_hash,1)
$(call AddDepends/crypto)
endef
+
$(eval $(call KernelPackage,crypto-hash))
+
define KernelPackage/crypto-manager
TITLE:=CryptoAPI algorithm manager
DEPENDS:=+kmod-crypto-hash
@@ -58,8 +61,10 @@ define KernelPackage/crypto-manager
AUTOLOAD:=$(call AutoLoad,03,$(foreach mod,$(CRYPTOMGR_MODULES),$(call crypto_name,$(mod))))
$(call AddDepends/crypto)
endef
+
$(eval $(call KernelPackage,crypto-manager))
+
define KernelPackage/crypto-pcompress
TITLE:=CryptoAPI Partial (de)compression operations
KCONFIG:= \
@@ -69,8 +74,10 @@ define KernelPackage/crypto-pcompress
AUTOLOAD:=$(call AutoLoad,09,pcompress)
$(call AddDepends/crypto)
endef
+
$(eval $(call KernelPackage,crypto-pcompress))
+
define KernelPackage/crypto-user
TITLE:=CryptoAPI userspace interface
DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
@@ -85,8 +92,10 @@ define KernelPackage/crypto-user
AUTOLOAD:=$(call AutoLoad,09,af_alg algif_hash algif_skcipher)
$(call AddDepends/crypto)
endef
+
$(eval $(call KernelPackage,crypto-user))
+
define KernelPackage/crypto-wq
TITLE:=CryptoAPI work queue handling
KCONFIG:=CONFIG_CRYPTO_WORKQUEUE
@@ -105,8 +114,10 @@ define KernelPackage/crypto-rng
AUTOLOAD:=$(call AutoLoad,09,rng krng)
$(call AddDepends/crypto)
endef
+
$(eval $(call KernelPackage,crypto-rng))
+
define KernelPackage/crypto-iv
TITLE:=CryptoAPI initialization vectors
DEPENDS:=+kmod-crypto-manager +kmod-crypto-rng +kmod-crypto-wq
@@ -117,8 +128,10 @@ define KernelPackage/crypto-iv
AUTOLOAD:=$(call AutoLoad,10,eseqiv chainiv)
$(call AddDepends/crypto)
endef
+
$(eval $(call KernelPackage,crypto-iv))
+
define KernelPackage/crypto-hw-talitos
TITLE:=Freescale integrated security engine (SEC) driver
DEPENDS:=+kmod-crypto-aes +kmod-crypto-manager +kmod-crypto-hash +kmod-random-core
@@ -254,6 +267,7 @@ endef
$(eval $(call KernelPackage,crypto-crc32c))
+
define KernelPackage/crypto-des
TITLE:=DES/3DES cipher CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_DES
@@ -264,6 +278,7 @@ endef
$(eval $(call KernelPackage,crypto-des))
+
define KernelPackage/crypto-deflate
TITLE:=Deflate compression CryptoAPI module
DEPENDS:=+kmod-lib-zlib
@@ -275,6 +290,7 @@ endef
$(eval $(call KernelPackage,crypto-deflate))
+
define KernelPackage/crypto-ecb
TITLE:=Electronic CodeBook CryptoAPI module
DEPENDS:=+kmod-crypto-manager
@@ -347,6 +363,7 @@ endef
$(eval $(call KernelPackage,crypto-sha1))
+
define KernelPackage/crypto-sha256
TITLE:=SHA224 SHA256 digest CryptoAPI module
DEPENDS:=+kmod-crypto-hash
@@ -358,6 +375,7 @@ endef
$(eval $(call KernelPackage,crypto-sha256))
+
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
camellia_mod_suffix=_generic
endif
@@ -404,7 +422,6 @@ define KernelPackage/crypto-misc
$(call AddDepends/crypto)
endef
-
define KernelPackage/crypto-misc/x86
FILES+=$(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko
endef
@@ -499,6 +516,7 @@ endef
$(eval $(call KernelPackage,crypto-xts))
+
define KernelPackage/crypto-mv-cesa
TITLE:=Marvell crypto engine
DEPENDS:=+kmod-crypto-manager +kmod-crypto-aes @TARGET_kirkwood||TARGET_orion||TARGET_mvebu