aboutsummaryrefslogtreecommitdiffstats
path: root/package/gnutls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/gnutls/Makefile')
-rw-r--r--package/gnutls/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/gnutls/Makefile b/package/gnutls/Makefile
index fdb3b13b0c..3e8a31ea99 100644
--- a/package/gnutls/Makefile
+++ b/package/gnutls/Makefile
@@ -35,7 +35,7 @@ $(PKG_BUILD_DIR)/.configured:
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -62,10 +62,9 @@ $(PKG_BUILD_DIR)/.configured:
--disable-srp-authentication \
--disable-anon-authentication \
--disable-openpgp-authentication \
- --with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
- --with-libopencdk-prefix="$(STAGING_DIR)/usr" \
- --with-libtasn1-prefix="$(STAGING_DIR)/usr" \
- --with-included-libcfg \
+ --with-included-opencdk=yes \
+ --with-included-libtasn1=yes \
+ --with-included-libcfg=yes \
--without-zlib \
--without-lzo \
);