aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-lantiq/patches/0030-MIPS-add-board-support-for-Gigaset-SX76X.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/boot/uboot-lantiq/patches/0030-MIPS-add-board-support-for-Gigaset-SX76X.patch')
-rw-r--r--package/boot/uboot-lantiq/patches/0030-MIPS-add-board-support-for-Gigaset-SX76X.patch22
1 files changed, 1 insertions, 21 deletions
diff --git a/package/boot/uboot-lantiq/patches/0030-MIPS-add-board-support-for-Gigaset-SX76X.patch b/package/boot/uboot-lantiq/patches/0030-MIPS-add-board-support-for-Gigaset-SX76X.patch
index 91c6263a7e..96737fa483 100644
--- a/package/boot/uboot-lantiq/patches/0030-MIPS-add-board-support-for-Gigaset-SX76X.patch
+++ b/package/boot/uboot-lantiq/patches/0030-MIPS-add-board-support-for-Gigaset-SX76X.patch
@@ -6,9 +6,6 @@ Subject: MIPS: add board support for Gigaset SX76X
Signed-off-by: Luka Perkov <luka@openwrt.org>
Signed-off-by: Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
-diff --git a/board/gigaset/sx76x/Makefile b/board/gigaset/sx76x/Makefile
-new file mode 100644
-index 0000000..3a547c2
--- /dev/null
+++ b/board/gigaset/sx76x/Makefile
@@ -0,0 +1,27 @@
@@ -39,9 +36,6 @@ index 0000000..3a547c2
+sinclude $(obj).depend
+
+#########################################################################
-diff --git a/board/gigaset/sx76x/config.mk b/board/gigaset/sx76x/config.mk
-new file mode 100644
-index 0000000..9d8953b
--- /dev/null
+++ b/board/gigaset/sx76x/config.mk
@@ -0,0 +1,7 @@
@@ -52,9 +46,6 @@ index 0000000..9d8953b
+#
+
+PLATFORM_CPPFLAGS += -I$(TOPDIR)/board/$(BOARDDIR)
-diff --git a/board/gigaset/sx76x/ddr_settings.h b/board/gigaset/sx76x/ddr_settings.h
-new file mode 100644
-index 0000000..13cd81b
--- /dev/null
+++ b/board/gigaset/sx76x/ddr_settings.h
@@ -0,0 +1,55 @@
@@ -113,9 +104,6 @@ index 0000000..13cd81b
+#define MC_DC44_VALUE 0x0
+#define MC_DC45_VALUE 0x500
+#define MC_DC46_VALUE 0x0
-diff --git a/board/gigaset/sx76x/sx76x.c b/board/gigaset/sx76x/sx76x.c
-new file mode 100644
-index 0000000..71996a1
--- /dev/null
+++ b/board/gigaset/sx76x/sx76x.c
@@ -0,0 +1,65 @@
@@ -184,11 +172,9 @@ index 0000000..71996a1
+
+ return switch_device_register(&adm6996i_dev);
+}
-diff --git a/boards.cfg b/boards.cfg
-index ea5c4f9..2163cdb 100644
--- a/boards.cfg
+++ b/boards.cfg
-@@ -510,6 +510,8 @@ Active mips mips32 danube arcadyan arv7518pw
+@@ -510,6 +510,8 @@ Active mips mips32 danub
Active mips mips32 danube arcadyan arv7518pw arv7518pw_ram arv7518pw:SYS_BOOT_RAM Luka Perkov <luka@openwrt.org>
Active mips mips32 danube audiocodes acmp252 acmp252_nor acmp252:SYS_BOOT_NOR Daniel Golle <daniel.golle@gmail.com>
Active mips mips32 danube audiocodes acmp252 acmp252_ram acmp252:SYS_BOOT_RAM Daniel Golle <daniel.golle@gmail.com>
@@ -197,9 +183,6 @@ index ea5c4f9..2163cdb 100644
Active mips mips32 danube lantiq easy50712 easy50712_nor easy50712:SYS_BOOT_NOR Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
Active mips mips32 danube lantiq easy50712 easy50712_norspl easy50712:SYS_BOOT_NORSPL Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
Active mips mips32 danube lantiq easy50712 easy50712_ram easy50712:SYS_BOOT_RAM Daniel Schwierzeck <daniel.schwierzeck@gmail.com>
-diff --git a/include/configs/sx76x.h b/include/configs/sx76x.h
-new file mode 100644
-index 0000000..236851e
--- /dev/null
+++ b/include/configs/sx76x.h
@@ -0,0 +1,59 @@
@@ -262,6 +245,3 @@ index 0000000..236851e
+ "kernel_addr=0xB0040000\0"
+
+#endif /* __CONFIG_H */
---
-1.8.3.2
-