aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
Diffstat (limited to 'include')
-rw-r--r--include/image.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 7c11aa1c13..bc383e6ba8 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -336,7 +336,11 @@ define Build/fit
endef
define Build/lzma
- $(STAGING_DIR_HOST)/bin/lzma e $@ -lc1 -lp2 -pb2 $(1) $@.new
+ $(call Build/lzma-no-dict,-lc1 -lp2 -pb2 $(1))
+endef
+
+define Build/lzma-no-dict
+ $(STAGING_DIR_HOST)/bin/lzma e $@ $(1) $@.new
@mv $@.new $@
endef