aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-26 11:43:24 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-26 11:43:24 +0000
commit9970ddf40b01db6186fe7224714999b0bd9eac33 (patch)
tree68b4cf6bcfd19d688b72ac01a390a4fc4f9a2134 /include
parentf80c35b9e34c17e739a107438817fbd37c28600c (diff)
downloadmaster-187ad058-9970ddf40b01db6186fe7224714999b0bd9eac33.tar.gz
master-187ad058-9970ddf40b01db6186fe7224714999b0bd9eac33.tar.bz2
master-187ad058-9970ddf40b01db6186fe7224714999b0bd9eac33.zip
include: add a no dict version of lzma to new image build code
Required to compress kernels in a brnboot compatible way. Signed-off-by: Mathias Kresin <openwrt@kresin.me> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49240 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 7c11aa1c13..bc383e6ba8 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -336,7 +336,11 @@ define Build/fit
endef
define Build/lzma
- $(STAGING_DIR_HOST)/bin/lzma e $@ -lc1 -lp2 -pb2 $(1) $@.new
+ $(call Build/lzma-no-dict,-lc1 -lp2 -pb2 $(1))
+endef
+
+define Build/lzma-no-dict
+ $(STAGING_DIR_HOST)/bin/lzma e $@ $(1) $@.new
@mv $@.new $@
endef