aboutsummaryrefslogtreecommitdiffstats
path: root/include/verbose.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/verbose.mk')
-rw-r--r--include/verbose.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/verbose.mk b/include/verbose.mk
index 525fbf1c15..36002aee99 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -18,13 +18,18 @@ ifeq ("$(origin V)", "command line")
KBUILD_VERBOSE:=$(V)
endif
+ifneq ($(shell tty -s <&3 || echo x),x)
+ _Y:="\\33[33m"# yellow
+ _N:="\\33[m"# normal
+endif
+
ifneq ($(KBUILD_VERBOSE),99)
ifeq ($(QUIET),1)
$(MAKECMDGOALS): trace
trace: FORCE
@[ -f "$(MAKECMDGOALS)" ] || { \
[ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
- echo -e "\33[33mmake[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)\33[m" >&3; \
+ echo -e "$(_Y)make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)$(_N)" >&3; \
}
else
export QUIET:=1