aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index dd8fcd6f30..2ee1518b8a 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -26,6 +26,12 @@ export IS_TTY=$(shell tty -s && echo 1 || echo 0)
export LD_LIBRARY_PATH:=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
export DYLD_LIBRARY_PATH:=$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
+# prevent perforce from messing with the patch utility
+export P4PORT=
+export P4USER=
+export P4CONFIG=
+export P4CLIENT=
+
# make sure that a predefined CFLAGS variable does not disturb packages
export CFLAGS=