aboutsummaryrefslogtreecommitdiffstats
path: root/include/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/modules.mk')
-rw-r--r--include/modules.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/include/modules.mk b/include/modules.mk
new file mode 100644
index 0000000000..026c4a6103
--- /dev/null
+++ b/include/modules.mk
@@ -0,0 +1,27 @@
+include $(TOPDIR)/include/kernel.mk
+
+define KernelPackage/ide-core
+TITLE:=Kernel support for IDE
+DESCRIPTION:=Kernel modules for IDE support\\\
+ useful for usb mass storage devices (e.g. on WL-HDD)\\\
+ \\\
+ Includes: \\\
+ - ide-core \\\
+ - ide-detect \\\
+ - ide-disk \\\
+ - pdc202xx_old
+KCONFIG:=CONFIG_IDE
+FILES:=$(MODULES_DIR)/kernel/drivers/ide/*.$(LINUX_KMOD_SUFFIX)
+MODULES:=$(call AutoLoad,20,ide-core) $(call AutoLoad,90,ide-detect ide-disk)
+endef
+$(eval $(call KernelPackage,ide-core))
+
+define KernelPackage/ide-pdc202xx
+TITLE:=PDC202xx IDE driver
+DESCRIPTION:=PDC202xx IDE driver
+KCONFIG:=CONFIG_BLK_DEV_PDC202XX_OLD
+FILES:=$(MODULES_DIR)/kernel/drivers/ide/pci/pdc202xx_old.$(LINUX_KMOD_SUFFIX)
+MODULES:=$(call AutoLoad,30,pdc202xx_old)
+endef
+$(eval $(call KernelPackage,ide-pdc202xx))
+