aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index e966188187..cd94233149 100644
--- a/Makefile
+++ b/Makefile
@@ -61,8 +61,11 @@ toolchain_install:
#
##############################################################
-package_install: toolchain
- $(MAKE) -C package compile install
+package_compile: target_compile
+ $(MAKE) -C package compile
+
+package_install: package_compile toolchain
+ $(MAKE) -C package install
#############################################################
#
@@ -91,6 +94,9 @@ package_index:
target_prepare:
$(MAKE) -C target prepare
+target_compile:
+ $(MAKE) -C target compile
+
target_install:
$(MAKE) -C target install