aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/crypto.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index ca36c2f2cc..9626b21fdb 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -511,12 +511,19 @@ $(eval $(call KernelPackage,crypto-sha256))
define KernelPackage/crypto-sha512
TITLE:=SHA512 digest CryptoAPI module
DEPENDS:=+kmod-crypto-hash
- KCONFIG:=CONFIG_CRYPTO_SHA512
+ KCONFIG:= \
+ CONFIG_CRYPTO_SHA512 \
+ CONFIG_CRYPTO_SHA512_OCTEON
FILES:=$(LINUX_DIR)/crypto/sha512_generic.ko
AUTOLOAD:=$(call AutoLoad,09,sha512_generic)
$(call AddDepends/crypto)
endef
+define KernelPackage/crypto-sha512/octeon
+ FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-sha512.ko
+ AUTOLOAD:=$(call AutoLoad,09,octeon-sha512)
+endef
+
$(eval $(call KernelPackage,crypto-sha512))