aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/default/sbin/mount_root13
2 files changed, 12 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index c1dd8c69fc..869e3c67d1 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -3,7 +3,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=base-files
-PKG_RELEASE:=2
+PKG_RELEASE:=4
PKG_BUILD_DIR:=$(BUILD_DIR)/base-files
REV:=${shell svn info | grep Revision | cut -d ' ' -f 2}
diff --git a/package/base-files/default/sbin/mount_root b/package/base-files/default/sbin/mount_root
index bc8d69c79b..c8edaaa2fa 100755
--- a/package/base-files/default/sbin/mount_root
+++ b/package/base-files/default/sbin/mount_root
@@ -1,10 +1,15 @@
#!/bin/sh
. /etc/nvram.sh
+is_clean() {
+ OFFSET="$((0x$(dd if=/dev/mtdblock/1 bs=1 skip=$((0x14)) count=2 2>&- | hexdump | grep 0000000 | cut -d ' ' -f 2) - 1))"
+ dd if=/dev/mtdblock/1 bs=1 skip=$OFFSET count=1 2>&- | hexdump -v | grep ' 0000' > /dev/null && return 255 || return 0
+}
+
if [ "$1" != "failsafe" ]; then
mount | grep jffs2 >&-
if [ $? = 0 ] ; then
if [ $(cat /proc/mtd | wc -l) = 6 ]; then
- [ -f /proc/sys/diag ] && echo 5 > /proc/sys/diag
+ echo 5 > /proc/sys/diag
mtd unlock linux
mtd erase OpenWrt
jffs2root --move
@@ -13,7 +18,11 @@ if [ "$1" != "failsafe" ]; then
mount -o remount,rw /dev/root /
fi
else
- if [ \! -x /usr/sbin/nvram -o -z "$(nvram get no_root_swap)" ]; then
+ if [ -z "$(nvram get no_root_swap)" ]; then
+ is_clean || {
+ mtd erase OpenWrt
+ jffs2root --clean
+ }
mtd unlock OpenWrt
mount -t jffs2 /dev/mtdblock/4 /jffs
pivot_root /jffs /jffs/rom