aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-build.mk1
-rw-r--r--rules.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 6aefe0b891..5544a82e37 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -4,6 +4,7 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+include $(INCLUDE_DIR)/host.mk
-include $(INCLUDE_DIR)/modules-$(KERNEL).mk
LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
diff --git a/rules.mk b/rules.mk
index b9859dbd3f..be269e77f3 100644
--- a/rules.mk
+++ b/rules.mk
@@ -84,6 +84,7 @@ RSTRIP:= \
# where to build (and put) .ipk packages
IPKG:= \
+ PATH="$(STAGING_DIR)/bin:$(PATH)" \
IPKG_TMP=$(BUILD_DIR)/tmp \
IPKG_INSTROOT=$(TARGET_DIR) \
IPKG_CONF_DIR=$(STAGING_DIR)/etc \