aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/crypto.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index f5c58954b8..2328fac043 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -492,12 +492,19 @@ $(eval $(call KernelPackage,crypto-sha1))
define KernelPackage/crypto-sha256
TITLE:=SHA224 SHA256 digest CryptoAPI module
DEPENDS:=+kmod-crypto-hash
- KCONFIG:=CONFIG_CRYPTO_SHA256
+ KCONFIG:= \
+ CONFIG_CRYPTO_SHA256 \
+ CONFIG_CRYPTO_SHA256_OCTEON
FILES:=$(LINUX_DIR)/crypto/sha256_generic.ko
AUTOLOAD:=$(call AutoLoad,09,sha256_generic)
$(call AddDepends/crypto)
endef
+define KernelPackage/crypto-sha256/octeon
+ FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-sha256.ko
+ AUTOLOAD:=$(call AutoLoad,09,octeon-sha256)
+endef
+
$(eval $(call KernelPackage,crypto-sha256))