aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in8
-rw-r--r--package/Makefile.in5
2 files changed, 7 insertions, 6 deletions
diff --git a/package/Config.in b/package/Config.in
index f7eff0639e..f22f83e608 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -2,15 +2,17 @@
menu "OpenWrt Package Selection"
-comment "The default set"
+comment "The absolute minimum"
+source "package/linux/Config.in"
source "package/busybox/Config.in"
+
+comment "The default set"
source "package/dnsmasq/Config.in"
-source "package/linux/Config.in"
source "package/iptables/Config.in"
source "package/bridge/Config.in"
comment "Suggested Extras"
-source "package/dropbear_sshd/Config.in"
source "package/ebtables/Config.in"
+source "package/dropbear_sshd/Config.in"
endmenu
diff --git a/package/Makefile.in b/package/Makefile.in
index e8ec23efcc..0d600d0a5a 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -1,5 +1,3 @@
-LINKSYS_TGZ_SITE=http://openwrt.openbsd-geek.de
-
MAKE1=make
MAKE=make -j$(BR2_JLEVEL)
@@ -17,8 +15,8 @@ TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
HOSTCC:=gcc
BASE_DIR:=${shell pwd}
DL_DIR:=$(BASE_DIR)/dl
-#PATCH_DIR=$(BASE_DIR)/sources/patches
BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)$(ARCH_FPU_SUFFIX)
+PACKAGE_DIR:=$(BASE_DIR)/package
TARGET_DIR:=$(BUILD_DIR)/root
TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)
# Strip off the annoying quoting
@@ -32,6 +30,7 @@ KERNEL_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)-linux-uclibc-
TARGET_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)-linux-uclibc-
TARGET_CC=$(TARGET_CROSS)gcc
STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
+PATCH=toolchain/patch-kernel.sh
HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \