aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/netsupport.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index fc85e22f41..376b588982 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -144,6 +144,20 @@ endef
$(eval $(call KernelPackage,8021q))
+define KernelPackage/vxlan
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Native VXLAN Kernel support
+ KCONFIG:=CONFIG_VXLAN
+ FILES:=$(LINUX_DIR)/drivers/net/vxlan.ko
+ AUTOLOAD:=$(call AutoLoad,13,vxlan)
+endef
+
+define KernelPackage/vxlan/description
+ Kernel module for supporting VXLAN in the Kernel.
+ Requires Kernel 3.12 or newer.
+endef
+
+$(eval $(call KernelPackage,vxlan))
define KernelPackage/capi
SUBMENU:=$(NETWORK_SUPPORT_MENU)