aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tools/mtd-utils/Makefile2
-rw-r--r--tools/sstrip/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/tools/mtd-utils/Makefile b/tools/mtd-utils/Makefile
index f67ccf758f..bc15f0a671 100644
--- a/tools/mtd-utils/Makefile
+++ b/tools/mtd-utils/Makefile
@@ -19,7 +19,7 @@ PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
include $(INCLUDE_DIR)/host-build.mk
CFLAGS := $(HOSTCFLAGS) -O2 -I../include
-ifneq ($(OS),Linux)
+ifneq ($(HOST_OS),Linux)
CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h -include endian.h
endif
diff --git a/tools/sstrip/Makefile b/tools/sstrip/Makefile
index dc3ff4f6da..4e409e0d8d 100644
--- a/tools/sstrip/Makefile
+++ b/tools/sstrip/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/host-build.mk
PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/sstrip
OS:=$(shell uname)
-ifeq ($(OS),Darwin)
+ifeq ($(HOST_OS),Darwin)
CFLAGS += -I./include
endif