aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-26 21:10:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-26 21:10:48 +0000
commit9fd4182b9994069e8543deda80ed3796ac94a0f3 (patch)
tree884d825fa44f460a4e36ccf4ec9758bd2265df3a /tools
parent2bafcfc69ac10cd6582f8c02f6532844e1baf341 (diff)
downloadmaster-187ad058-9fd4182b9994069e8543deda80ed3796ac94a0f3.tar.gz
master-187ad058-9fd4182b9994069e8543deda80ed3796ac94a0f3.tar.bz2
master-187ad058-9fd4182b9994069e8543deda80ed3796ac94a0f3.zip
bison: replace the yacc script with one that does not hardcode the path (fixes #20605)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47050 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/bison/Makefile5
-rwxr-xr-xtools/bison/scripts/yacc2
2 files changed, 7 insertions, 0 deletions
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
index 10d8720484..256512116f 100644
--- a/tools/bison/Makefile
+++ b/tools/bison/Makefile
@@ -23,4 +23,9 @@ define Host/Clean
$(call Host/Clean/Default)
endef
+define Host/Install
+ $(call Host/Install/Default)
+ $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
$(eval $(call HostBuild))
diff --git a/tools/bison/scripts/yacc b/tools/bison/scripts/yacc
new file mode 100755
index 0000000000..8f73e26fb1
--- /dev/null
+++ b/tools/bison/scripts/yacc
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec bison -y "$@"