aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-09-14 14:03:21 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-09-14 14:03:21 +0000
commit42f39be86e5d45c4adf3c5673dc62a87881dce8e (patch)
tree3e5f33db566455a3c4f43b03a57e554d8f0ea643 /tools
parentdd8265346f6d49ee850615ae77d78d6bffad80f5 (diff)
downloadmaster-187ad058-42f39be86e5d45c4adf3c5673dc62a87881dce8e.tar.gz
master-187ad058-42f39be86e5d45c4adf3c5673dc62a87881dce8e.tar.bz2
master-187ad058-42f39be86e5d45c4adf3c5673dc62a87881dce8e.zip
tools/xz: disable shared library
Force a static build of the xz utilities in order to avoid the dependency on a shared liblzma.so which might collide with the distro version. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46907 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/xz/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/tools/xz/Makefile b/tools/xz/Makefile
index e266667957..d1f10081ae 100644
--- a/tools/xz/Makefile
+++ b/tools/xz/Makefile
@@ -17,6 +17,10 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+HOST_CONFIGURE_ARGS += \
+ --enable-static=yes \
+ --enable-shared=no \
+
define Host/Install
+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
endef