aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xz
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-12 12:34:30 +0000
commitf120a607293fcb09054ba34dc0491e8c31561375 (patch)
tree7ca8e633445d23dee7adb03246b4127a87c12079 /tools/xz
parente51c7c8ba15543f4f88897631005e7857819b12c (diff)
downloadmaster-187ad058-f120a607293fcb09054ba34dc0491e8c31561375.tar.gz
master-187ad058-f120a607293fcb09054ba34dc0491e8c31561375.tar.bz2
master-187ad058-f120a607293fcb09054ba34dc0491e8c31561375.zip
[tools] use HOST_STATIC_LINKING instead of hardcoding -static
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33140 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/xz')
-rw-r--r--tools/xz/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/xz/Makefile b/tools/xz/Makefile
index 41894e073c..b1698be99e 100644
--- a/tools/xz/Makefile
+++ b/tools/xz/Makefile
@@ -15,10 +15,11 @@ PKG_MD5SUM:=8d900b742b94fa9e708ca4f5a4b29003
include $(INCLUDE_DIR)/host-build.mk
-HOST_LDFLAGS += -static
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
define Host/Install
- $(MAKE) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat" AM_LDFLAGS="-all-static"
+ $(MAKE) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat" \
+ AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
endef
$(eval $(call HostBuild))