aboutsummaryrefslogtreecommitdiffstats
path: root/tools/upx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-22 12:52:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-22 12:52:21 +0000
commit037194a1909e1707d7ca46b2e10794c7bf7b8bf0 (patch)
tree691771bdbc7edd2214d51ddad3369d76b6b7ec03 /tools/upx
parentcd9eb981deac8171c5d16b9c6ac880f47f2cdbbd (diff)
downloadmaster-187ad058-037194a1909e1707d7ca46b2e10794c7bf7b8bf0.tar.gz
master-187ad058-037194a1909e1707d7ca46b2e10794c7bf7b8bf0.tar.bz2
master-187ad058-037194a1909e1707d7ca46b2e10794c7bf7b8bf0.zip
tools/upx: use HOSTCXX to fix build errors on mac os x
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36110 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/upx')
-rw-r--r--tools/upx/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/upx/Makefile b/tools/upx/Makefile
index 3e76232012..c162e557cb 100644
--- a/tools/upx/Makefile
+++ b/tools/upx/Makefile
@@ -21,7 +21,8 @@ include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
rm -f $(HOST_BUILD_DIR)/src/.depend
$(MAKE) UPX_LZMADIR="$(BUILD_DIR_HOST)/lzma-4.65" -C $(HOST_BUILD_DIR)/src \
- CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)"
+ CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)" \
+ CXX="$(HOSTCXX)"
endef
define Host/Install