aboutsummaryrefslogtreecommitdiffstats
path: root/tools/upslug2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-12-12 02:00:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-12-12 02:00:50 +0000
commit6599c8df669b16f15660b03d6a2aa60d0fe730fd (patch)
tree26c267b1edc29d414f72c80b9b53d8147aa8f2b7 /tools/upslug2/Makefile
parenta1d28a0f3c74734bc420e64c8b5ed1696bb7a000 (diff)
downloadmaster-187ad058-6599c8df669b16f15660b03d6a2aa60d0fe730fd.tar.gz
master-187ad058-6599c8df669b16f15660b03d6a2aa60d0fe730fd.tar.bz2
master-187ad058-6599c8df669b16f15660b03d6a2aa60d0fe730fd.zip
add a hacked up version of upslug2 which is able to flash a wrt350nv2 in recovery mode
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18765 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/upslug2/Makefile')
-rw-r--r--tools/upslug2/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/tools/upslug2/Makefile b/tools/upslug2/Makefile
new file mode 100644
index 0000000000..6a73853f3c
--- /dev/null
+++ b/tools/upslug2/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=upslug2
+PKG_VERSION:=20071227
+
+PKG_SOURCE_URL:=http://svn.nslu2-linux.org/svnroot/upslug2/trunk
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_SUBDIR:=upslug2-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=41
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); \
+ aclocal && autoconf && \
+ autoheader && \
+ automake --add-missing; \
+ )
+ $(Host/Configure/Default)
+endef
+
+ifneq ($(HOST_OS),Linux)
+ HOST_CONFIGURE_ARGS += --with-libpcap
+endif
+
+$(eval $(call HostBuild))