aboutsummaryrefslogtreecommitdiffstats
path: root/tools/sstrip
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
commitb892e1fb855de59ce8e81881526ede35df1ae3fd (patch)
tree8497134d453d336d68b5dbf67d9b6b719ed2145e /tools/sstrip
parent67c9c212e61d7ce11aa22e3ac5f7a109c134c0d1 (diff)
downloadmaster-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.tar.gz
master-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.tar.bz2
master-187ad058-b892e1fb855de59ce8e81881526ede35df1ae3fd.zip
build system refactoring in preparation for allowing packages to do host-build steps
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14610 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/sstrip')
-rw-r--r--tools/sstrip/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/tools/sstrip/Makefile b/tools/sstrip/Makefile
index 8d23e36e8b..d93e7618d1 100644
--- a/tools/sstrip/Makefile
+++ b/tools/sstrip/Makefile
@@ -10,15 +10,15 @@ PKG_NAME:=sstrip
include $(INCLUDE_DIR)/host-build.mk
-define Build/Compile
- $(CC) $(HOST_CFLAGS) -I./include -include endian.h -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
+define Host/Compile
+ $(CC) $(HOST_CFLAGS) -I./include -include endian.h -o $(HOST_BUILD_DIR)/sstrip src/sstrip.c
endef
-define Build/Install
- $(CP) $(PKG_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
+define Host/Install
+ $(CP) $(HOST_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
endef
-define Build/Clean
+define Host/Clean
rm -f $(STAGING_DIR_HOST)/bin/sstrip
endef