aboutsummaryrefslogtreecommitdiffstats
path: root/tools/sed
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-07-26 18:09:20 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-07-26 18:09:20 +0000
commitd5a89db71431c74d5a451bed28ffb5b77faf9fc3 (patch)
treecb2156392a6d96188f0b7eb33850b75e99dd6a40 /tools/sed
parent50cc5085d47bee79beef66f12e12db81e7d9e368 (diff)
downloadmaster-187ad058-d5a89db71431c74d5a451bed28ffb5b77faf9fc3.tar.gz
master-187ad058-d5a89db71431c74d5a451bed28ffb5b77faf9fc3.tar.bz2
master-187ad058-d5a89db71431c74d5a451bed28ffb5b77faf9fc3.zip
[tools] override sed configuration to work with FreeBSD (#4531)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17022 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/sed')
-rw-r--r--tools/sed/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/sed/Makefile b/tools/sed/Makefile
index f15299c96c..423e2982e0 100644
--- a/tools/sed/Makefile
+++ b/tools/sed/Makefile
@@ -17,6 +17,14 @@ export SED:=
include $(INCLUDE_DIR)/host-build.mk
+define Build/Configure
+ ( cd $(PKG_BUILD_DIR); \
+ ./configure \
+ --prefix=$(STAGING_DIR_HOST) \
+ --infodir=/usr/info \
+ )
+endef
+
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)"
endef