aboutsummaryrefslogtreecommitdiffstats
path: root/tools/sed
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 22:29:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 22:29:46 +0000
commit8c7c8aac5a0a11ba279c8ddc424f17fcbca9ac68 (patch)
tree33ffa61c05fc80f9e56e8bcabd5c5b5ccdc0896d /tools/sed
parent93f9a87efc6ac45b766cd55a1914a385b4cf11a7 (diff)
downloadmaster-187ad058-8c7c8aac5a0a11ba279c8ddc424f17fcbca9ac68.tar.gz
master-187ad058-8c7c8aac5a0a11ba279c8ddc424f17fcbca9ac68.tar.bz2
master-187ad058-8c7c8aac5a0a11ba279c8ddc424f17fcbca9ac68.zip
always build sed, some systems have a broken one where it's hard to detect
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5043 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/sed')
-rw-r--r--tools/sed/Makefile31
-rwxr-xr-xtools/sed/sedcheck.sh24
2 files changed, 8 insertions, 47 deletions
diff --git a/tools/sed/Makefile b/tools/sed/Makefile
index b3169918b4..61c7acbb00 100644
--- a/tools/sed/Makefile
+++ b/tools/sed/Makefile
@@ -16,29 +16,23 @@ PKG_CAT:=zcat
PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-HOST_SED_TARGET=$(strip $(shell ./sedcheck.sh))
-
-ifneq ($(HOST_SED_TARGET),build-sed-host-binary)
- PKG_SOURCE:=
- PKG_CAT:=
-endif
-
include $(INCLUDE_DIR)/host-build.mk
-ifeq ($(HOST_SED_TARGET),build-sed-host-binary)
- define Build/Configure
+override SHELL:=$(BASH)
+
+define Build/Configure
(cd $(PKG_BUILD_DIR); rm -rf config.cache; \
./configure \
--prefix=$(STAGING_DIR) \
--prefix=/usr \
);
- endef
+endef
- define Build/Compile
+define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)
- endef
+endef
- define Build/Install
+define Build/Install
@if [ -L $(STAGING_DIR)/bin/sed ] ; then \
rm -f $(STAGING_DIR)/bin/sed; fi;
@if [ ! -f $(STAGING_DIR)/bin/sed -o $(STAGING_DIR)/bin/sed -ot $(PKG_BUILD_DIR)/sed/sed ]; then \
@@ -49,15 +43,6 @@ ifeq ($(HOST_SED_TARGET),build-sed-host-binary)
rm -rf $(STAGING_DIR)/share/locale $(STAGING_DIR)/usr/info \
$(STAGING_DIR)/usr/man $(STAGING_DIR)/usr/share/doc; \
fi
- endef
-else
- define Build/Compile
- endef
- define Build/Install
- rm -rf $(STAGING_DIR)/bin/sed
- mkdir -p $(STAGING_DIR)/bin
- ln -s `which sed` $(STAGING_DIR)/bin/sed
- endef
-endif
+endef
$(eval $(call HostBuild))
diff --git a/tools/sed/sedcheck.sh b/tools/sed/sedcheck.sh
deleted file mode 100755
index f5a09fde08..0000000000
--- a/tools/sed/sedcheck.sh
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-
-if [ -x /usr/bin/sed ]; then
- SED="/usr/bin/sed";
-else
- if [ -x /bin/sed ]; then
- SED="/bin/sed";
- fi;
-fi;
-
-echo "HELLO" > .sedtest
-$SED -i -e "s/HELLO/GOODBYE/" .sedtest >/dev/null 2>&1
-
-case "$1" in
- *)
- if [ $? != 0 ] ; then
- echo build-sed-host-binary
- else
- echo use-sed-host-binary
- fi;
- ;;
-esac
-rm -f .sedtest*
-