aboutsummaryrefslogtreecommitdiffstats
path: root/tools/scons
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-05 17:37:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-05 17:37:34 +0000
commit768f0c40f8e1c389b1534a1ed456ead533ecffd0 (patch)
tree43b16f5b9a278f2b2adc1646986510c220ed24d6 /tools/scons
parent817b19be2928ac6b650dc3891c9be86f5c0b9c91 (diff)
downloadmaster-187ad058-768f0c40f8e1c389b1534a1ed456ead533ecffd0.tar.gz
master-187ad058-768f0c40f8e1c389b1534a1ed456ead533ecffd0.tar.bz2
master-187ad058-768f0c40f8e1c389b1534a1ed456ead533ecffd0.zip
tools: add scons (patch by Dave Taht)
This makes it more possible to build scons based applications for openwrt. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31618 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/scons')
-rw-r--r--tools/scons/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/tools/scons/Makefile b/tools/scons/Makefile
new file mode 100644
index 0000000000..aadeb289a2
--- /dev/null
+++ b/tools/scons/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=scons
+PKG_VERSION:=2.1.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/scons
+PKG_MD5SUM:=47daf989e303a045b76c11236df719df
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+ python $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
+endef
+
+$(eval $(call HostBuild))