aboutsummaryrefslogtreecommitdiffstats
path: root/tools/scons/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-05-15 20:04:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-05-15 20:04:07 +0000
commit58b75ad2b1ce23661388c8a1e1bbb0b4a110b8d5 (patch)
tree845aed7cb85128b08b69363b7a44469168ec3023 /tools/scons/Makefile
parentf61eb18b665390d858ba3e49a41dbdd930cc7577 (diff)
downloadmaster-187ad058-58b75ad2b1ce23661388c8a1e1bbb0b4a110b8d5.tar.gz
master-187ad058-58b75ad2b1ce23661388c8a1e1bbb0b4a110b8d5.tar.bz2
master-187ad058-58b75ad2b1ce23661388c8a1e1bbb0b4a110b8d5.zip
[tools] scons: wrap python invocations with helper script that attempts to find a non-3.x python
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31742 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/scons/Makefile')
-rw-r--r--tools/scons/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/tools/scons/Makefile b/tools/scons/Makefile
index aadeb289a2..83c1c584a5 100644
--- a/tools/scons/Makefile
+++ b/tools/scons/Makefile
@@ -23,7 +23,12 @@ define Host/Compile
endef
define Host/Install
- python $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
+ ./files/pywrap.sh $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
+ rm -f $(STAGING_DIR_HOST)/bin/scons*.py
+ for bin in $(STAGING_DIR_HOST)/bin/scons*; do \
+ mv "$$$$bin" "$$$$bin.py"; \
+ cp ./files/pywrap.sh "$$$$bin"; \
+ done
endef
$(eval $(call HostBuild))