aboutsummaryrefslogtreecommitdiffstats
path: root/tools/quilt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-25 19:02:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-25 19:02:48 +0000
commitf81c8fd722ef377d19d80a789737084d1fc5ff9f (patch)
treebe210579a6cfb9e2fe345cafa904bf6833d2f47c /tools/quilt
parent62a6e10227efed2cfa1200710441768d2017a713 (diff)
downloadmaster-187ad058-f81c8fd722ef377d19d80a789737084d1fc5ff9f.tar.gz
master-187ad058-f81c8fd722ef377d19d80a789737084d1fc5ff9f.tar.bz2
master-187ad058-f81c8fd722ef377d19d80a789737084d1fc5ff9f.zip
detect quilt configure errors properly (their broken configure script does not return proper error codes)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14181 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/quilt')
-rw-r--r--tools/quilt/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
index 49da92b734..5294534b01 100644
--- a/tools/quilt/Makefile
+++ b/tools/quilt/Makefile
@@ -15,6 +15,11 @@ PKG_MD5SUM:=d33d2442bd34387260b1c1db3e623af0
include $(INCLUDE_DIR)/host-build.mk
+define Build/Configure
+ $(call Build/Configure/Default)
+ [ -f $(PKG_BUILD_DIR)/Makefile ]
+endef
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) SHELL="$(BASH)"
endef