aboutsummaryrefslogtreecommitdiffstats
path: root/tools/quilt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-07 17:32:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-07 17:32:29 +0000
commitcf3d83fe4a758c9fc0dc2e575b90c77f4fe18df8 (patch)
treee8523fabf4000faec51681f5e2c90940f9382291 /tools/quilt
parentd32fdeb4c0dc838022fc38b50191d482f2cca20c (diff)
downloadmaster-187ad058-cf3d83fe4a758c9fc0dc2e575b90c77f4fe18df8.tar.gz
master-187ad058-cf3d83fe4a758c9fc0dc2e575b90c77f4fe18df8.tar.bz2
master-187ad058-cf3d83fe4a758c9fc0dc2e575b90c77f4fe18df8.zip
build: BSD compile fixes
following patch allows to build images for Qemu ARM on OpenBSD 5.2 amd64 and FreeBSD 9.1 amd64. Mostly small pieces of code changes to get things right on the specific platform. Updated the README to describe better, which tools on the host are required. Added some kind of prepare scripts to install needed tools on BSD via packages. Signed-off-by: Waldemar Brodkorb <mail@waldemar-brodkorb.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35900 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/quilt')
-rw-r--r--tools/quilt/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
index 510d8f6fd5..541e656aff 100644
--- a/tools/quilt/Makefile
+++ b/tools/quilt/Makefile
@@ -15,12 +15,8 @@ PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
include $(INCLUDE_DIR)/host-build.mk
-GETOPT:=$(shell which getopt)
-
HOST_CONFIGURE_ARGS += \
- --with-patch=$(PATCH) \
- --with-find=$(FIND) \
- --with-getopt=$(GETOPT)
+ --with-find=$(FIND)
define Host/Configure
cd $(HOST_BUILD_DIR) && autoconf