aboutsummaryrefslogtreecommitdiffstats
path: root/tools/quilt
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-02 12:53:32 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-02 12:53:32 +0000
commit5506e60734e447c505763a654fe93703781090cc (patch)
tree8583efd32a04a0ac8f322de76e72f00f0b3d50ac /tools/quilt
parentd78ee5b5becdeb2325e1cea35e47a19848a97bbe (diff)
downloadmaster-187ad058-5506e60734e447c505763a654fe93703781090cc.tar.gz
master-187ad058-5506e60734e447c505763a654fe93703781090cc.tar.bz2
master-187ad058-5506e60734e447c505763a654fe93703781090cc.zip
[PATCH] quilt: fix building with dash
`test x == x` gives a syntax error with dash (standard in Debian). The modified patch reflects the current upstream: http://git.savannah.gnu.org/cgit/quilt.git/commit/?id=38df0b210c3df67f3e784af92232ae1946b98ecd git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26804 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/quilt')
-rw-r--r--tools/quilt/patches/100-patch_2.6.1_version.patch8
1 files changed, 6 insertions, 2 deletions
diff --git a/tools/quilt/patches/100-patch_2.6.1_version.patch b/tools/quilt/patches/100-patch_2.6.1_version.patch
index 84f275318c..1e9ed75df1 100644
--- a/tools/quilt/patches/100-patch_2.6.1_version.patch
+++ b/tools/quilt/patches/100-patch_2.6.1_version.patch
@@ -1,11 +1,15 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -274,7 +274,7 @@ fi
+@@ -274,7 +274,11 @@ fi
AC_MSG_CHECKING([the version of $PATCH])
if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
set -- `$PATCH --version 2> /dev/null`
- patch_version=$2
-+ test $2 == "patch" && patch_version=$3 || patch_version=$2
++ if test x$1 = xGNU ; then
++ patch_version=$3
++ else
++ patch_version=$2
++ fi
AC_MSG_RESULT($patch_version)
saved_IFS=$IFS; IFS='.'
set -- $patch_version