aboutsummaryrefslogtreecommitdiffstats
path: root/tools/quilt
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-07-27 17:21:30 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-07-27 17:21:30 +0000
commit369fae1a4c629cf436e8a06aabd74c40c01fdede (patch)
treee08c8b83c2e0a603870e2c72c289b22ad6f6b25c /tools/quilt
parent520b6d0ce0916406ed05df5ac2fb91f31b0e03cd (diff)
downloadmaster-187ad058-369fae1a4c629cf436e8a06aabd74c40c01fdede.tar.gz
master-187ad058-369fae1a4c629cf436e8a06aabd74c40c01fdede.tar.bz2
master-187ad058-369fae1a4c629cf436e8a06aabd74c40c01fdede.zip
tools/quilt: fix openSUSE/patch-2.6.1.81 issue (closes #7635)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22397 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/quilt')
-rw-r--r--tools/quilt/Makefile1
-rw-r--r--tools/quilt/patches/100-patch_2.6.1_version.patch11
2 files changed, 12 insertions, 0 deletions
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
index b973eb404f..221398f29b 100644
--- a/tools/quilt/Makefile
+++ b/tools/quilt/Makefile
@@ -16,6 +16,7 @@ PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
include $(INCLUDE_DIR)/host-build.mk
define Host/Configure
+ cd $(HOST_BUILD_DIR) && autoconf
$(call Host/Configure/Default)
[ -f $(HOST_BUILD_DIR)/Makefile ]
endef
diff --git a/tools/quilt/patches/100-patch_2.6.1_version.patch b/tools/quilt/patches/100-patch_2.6.1_version.patch
new file mode 100644
index 0000000000..84f275318c
--- /dev/null
+++ b/tools/quilt/patches/100-patch_2.6.1_version.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,7 +274,7 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+ set -- `$PATCH --version 2> /dev/null`
+- patch_version=$2
++ test $2 == "patch" && patch_version=$3 || patch_version=$2
+ AC_MSG_RESULT($patch_version)
+ saved_IFS=$IFS; IFS='.'
+ set -- $patch_version