aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ppl
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-12-15 21:07:34 +0000
committerLuka Perkov <luka@openwrt.org>2013-12-15 21:07:34 +0000
commitd955f368eff66d4cb3012b4911d7e3321d1af238 (patch)
treedfa89d5f638215a5ea068ed2208e7e1a1354c193 /tools/ppl
parent2fd6dbe8fd896301e6ad47ddb197ed2fd7125fa2 (diff)
downloadmaster-187ad058-d955f368eff66d4cb3012b4911d7e3321d1af238.tar.gz
master-187ad058-d955f368eff66d4cb3012b4911d7e3321d1af238.tar.bz2
master-187ad058-d955f368eff66d4cb3012b4911d7e3321d1af238.zip
[tools] ppl: update to 1.1
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39068 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/ppl')
-rw-r--r--tools/ppl/Makefile6
-rw-r--r--tools/ppl/patches/001-disable-serial-tests.patch44
-rw-r--r--tools/ppl/patches/001-gmp-conflicts.patch41
3 files changed, 47 insertions, 44 deletions
diff --git a/tools/ppl/Makefile b/tools/ppl/Makefile
index 2f54c30c7d..082b200e4a 100644
--- a/tools/ppl/Makefile
+++ b/tools/ppl/Makefile
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ppl
-PKG_VERSION:=1.0
+PKG_VERSION:=1.1
-PKG_SOURCE_URL:=http://bugseng.com/products/ppl/download/ftp/releases/1.0/
+PKG_SOURCE_URL:=http://bugseng.com/products/ppl/download/ftp/releases/$(PKG_VERSION)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_MD5SUM:=e8caeb84cd858f64b36333c368891c7b
+PKG_MD5SUM:=82617a9c4e08606111ed9d2dc37ececa
HOST_FIXUP:=autoreconf
diff --git a/tools/ppl/patches/001-disable-serial-tests.patch b/tools/ppl/patches/001-disable-serial-tests.patch
new file mode 100644
index 0000000000..91b0753feb
--- /dev/null
+++ b/tools/ppl/patches/001-disable-serial-tests.patch
@@ -0,0 +1,44 @@
+--- a/tests/BD_Shape/Makefile.am
++++ b/tests/BD_Shape/Makefile.am
+@@ -21,8 +21,6 @@
+ # For the most up-to-date information see the Parma Polyhedra Library
+ # site: http://bugseng.com/products/ppl/ .
+
+-AUTOMAKE_OPTIONS = serial-tests
+-
+ if VALGRIND_TESTS_ENABLED
+
+ CHECKER = \
+--- a/tests/Box/Makefile.am
++++ b/tests/Box/Makefile.am
+@@ -21,8 +21,6 @@
+ # For the most up-to-date information see the Parma Polyhedra Library
+ # site: http://bugseng.com/products/ppl/ .
+
+-AUTOMAKE_OPTIONS = serial-tests
+-
+ if VALGRIND_TESTS_ENABLED
+
+ CHECKER = \
+--- a/tests/Concrete_Expression/Makefile.am
++++ b/tests/Concrete_Expression/Makefile.am
+@@ -21,8 +21,6 @@
+ # For the most up-to-date information see the Parma Polyhedra Library
+ # site: http://bugseng.com/products/ppl/ .
+
+-AUTOMAKE_OPTIONS = serial-tests
+-
+ if VALGRIND_TESTS_ENABLED
+
+ CHECKER = \
+--- a/tests/Octagonal_Shape/Makefile.am
++++ b/tests/Octagonal_Shape/Makefile.am
+@@ -21,8 +21,6 @@
+ # For the most up-to-date information see the Parma Polyhedra Library
+ # site: http://bugseng.com/products/ppl/ .
+
+-AUTOMAKE_OPTIONS = serial-tests
+-
+ if VALGRIND_TESTS_ENABLED
+
+ CHECKER = \
diff --git a/tools/ppl/patches/001-gmp-conflicts.patch b/tools/ppl/patches/001-gmp-conflicts.patch
deleted file mode 100644
index cf65ee5245..0000000000
--- a/tools/ppl/patches/001-gmp-conflicts.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- a/src/mp_std_bits.cc
-+++ b/src/mp_std_bits.cc
-@@ -25,6 +25,9 @@ site: http://bugseng.com/products/ppl/ . */
- #include "ppl-config.h"
- #include "mp_std_bits_defs.hh"
-
-+#if __GNU_MP_VERSION < 5 \
-+ || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
-+
- const bool std::numeric_limits<mpz_class>::is_specialized;
- const int std::numeric_limits<mpz_class>::digits;
- const int std::numeric_limits<mpz_class>::digits10;
-@@ -70,3 +73,6 @@ const bool std::numeric_limits<mpq_class>::is_modulo;
- const bool std::numeric_limits<mpq_class>::traps;
- const bool std::numeric_limits<mpq_class>::tininess_before;
- const std::float_round_style std::numeric_limits<mpq_class>::round_style;
-+
-+#endif // __GNU_MP_VERSION < 5
-+ // || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
---- a/src/mp_std_bits.defs.hh
-+++ b/src/mp_std_bits.defs.hh
-@@ -38,6 +38,9 @@
- #endif // defined(PPL_DOXYGEN_INCLUDE_IMPLEMENTATION_DETAILS)
- void swap(mpq_class& x, mpq_class& y);
-
-+#if __GNU_MP_VERSION < 5 \
-+ || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
-+
- namespace std {
-
- #ifdef PPL_DOXYGEN_INCLUDE_IMPLEMENTATION_DETAILS
-@@ -164,6 +167,9 @@
-
- } // namespace std
-
-+#endif // __GNU_MP_VERSION < 5
-+ // || (__GNU_MP_VERSION == 5 && __GNU_MP_VERSION_MINOR < 1)
-+
- #include "mp_std_bits.inlines.hh"
-
- #endif // !defined(PPL_mp_std_bits_defs_hh)