aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pkg-config
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2007-10-06 23:50:47 +0000
committerJohn Crispin <blogic@openwrt.org>2007-10-06 23:50:47 +0000
commitcad1b620581f190548505014c91c17729fabac94 (patch)
tree0303d290259245f16a5feb334bf9f75a27b213e9 /tools/pkg-config
parent0b3ef78e450af9522061644d7a27e413b0a9cec2 (diff)
downloadmaster-187ad058-cad1b620581f190548505014c91c17729fabac94.tar.gz
master-187ad058-cad1b620581f190548505014c91c17729fabac94.tar.bz2
master-187ad058-cad1b620581f190548505014c91c17729fabac94.zip
added our own pkg-config wrapper, making the sed foo on *.pc files obselete 1/2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9162 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/pkg-config')
-rw-r--r--tools/pkg-config/Makefile35
-rwxr-xr-xtools/pkg-config/files/pkg-config3
2 files changed, 38 insertions, 0 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
new file mode 100644
index 0000000000..bcae2dfa69
--- /dev/null
+++ b/tools/pkg-config/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pkg-config
+PKG_VERSION:=0.22
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
+PKG_MD5SUM:=fd5c547e9d66ba49bc735ccb8c791f2a
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ install
+ mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
+ $(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
+endef
+
+define Build/Clean
+ $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/pkg-config/files/pkg-config b/tools/pkg-config/files/pkg-config
new file mode 100755
index 0000000000..31cfd0d83d
--- /dev/null
+++ b/tools/pkg-config/files/pkg-config
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pkg-config.real $@ --define-variable=libdir=${STAGING_DIR}/usr/lib --define-variable=includedir=${STAGING_DIR}/usr/include