aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pkg-config
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:26:46 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-10 19:26:46 +0000
commit94899ac6affa721d19ffc9ae03856a459b7e83b1 (patch)
treeb16190b8869d108561182fceae3b22cb8a72e75a /tools/pkg-config
parent0459a4f5d5c5f7a2c02b9f267b5640e69c417e6d (diff)
downloadmaster-187ad058-94899ac6affa721d19ffc9ae03856a459b7e83b1.tar.gz
master-187ad058-94899ac6affa721d19ffc9ae03856a459b7e83b1.tar.bz2
master-187ad058-94899ac6affa721d19ffc9ae03856a459b7e83b1.zip
[tools] pkg-config: link statically
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33102 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/pkg-config')
-rw-r--r--tools/pkg-config/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index e7d2982f7f..fbdc1d0db7 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -15,9 +15,10 @@ PKG_MD5SUM:=a3270bab3f4b69b7dc6dbdacbcae9745
include $(INCLUDE_DIR)/host-build.mk
+HOST_LDFLAGS += -static
+
define Host/Install
- $(MAKE) -C $(HOST_BUILD_DIR) \
- install
+ $(MAKE) -C $(HOST_BUILD_DIR) install AM_LDFLAGS="-all-static"
mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
$(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
endef