aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mtd-utils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-02-24 23:02:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-02-24 23:02:38 +0000
commit81aeef89072811a5e81d0cb4d83c44c93b1cdab2 (patch)
tree635c552ca235e6c8d44b4e7b41772f0424d6961c /tools/mtd-utils
parent93aae29643436528ff33a425a80a93fd09f1a1b4 (diff)
downloadmaster-187ad058-81aeef89072811a5e81d0cb4d83c44c93b1cdab2.tar.gz
master-187ad058-81aeef89072811a5e81d0cb4d83c44c93b1cdab2.tar.bz2
master-187ad058-81aeef89072811a5e81d0cb4d83c44c93b1cdab2.zip
mtd-utils: do not try to compile in support for ubifs ioctls and extended flags - some linux distros do not support this
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19846 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/mtd-utils')
-rw-r--r--tools/mtd-utils/Makefile2
-rw-r--r--tools/mtd-utils/patches/110-portability.patch8
2 files changed, 5 insertions, 5 deletions
diff --git a/tools/mtd-utils/Makefile b/tools/mtd-utils/Makefile
index 45a61ab3c3..45bceaf837 100644
--- a/tools/mtd-utils/Makefile
+++ b/tools/mtd-utils/Makefile
@@ -21,7 +21,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
-CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib
+CFLAGS := $(HOST_CFLAGS) -I$(HOST_BUILD_DIR)/include -L$(HOST_BUILD_DIR) -L$(STAGING_DIR_HOST)/lib -DNO_NATIVE_SUPPORT
ifneq ($(HOST_OS),Linux)
CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -include getline.h -include endian.h -I$(CURDIR)/include -include fls.h
endif
diff --git a/tools/mtd-utils/patches/110-portability.patch b/tools/mtd-utils/patches/110-portability.patch
index 3d0037c90a..d35b446587 100644
--- a/tools/mtd-utils/patches/110-portability.patch
+++ b/tools/mtd-utils/patches/110-portability.patch
@@ -92,7 +92,7 @@
if (c->default_compr != UBIFS_COMPR_NONE)
use_flags |= UBIFS_COMPR_FL;
-+#ifdef __linux__
++#ifndef NO_NATIVE_SUPPORT
if (flags & FS_COMPR_FL)
use_flags |= UBIFS_COMPR_FL;
if (flags & FS_SYNC_FL)
@@ -108,7 +108,7 @@
fd = dirfd(dir);
if (fd == -1)
return sys_err_msg("dirfd failed");
-+#ifdef __linux__
++#ifndef NO_NATIVE_SUPPORT
if (ioctl(fd, FS_IOC_GETFLAGS, &flags) == -1)
+#endif
flags = 0;
@@ -118,7 +118,7 @@
key_write(&key, &dn->key);
dn->size = cpu_to_le32(bytes_read);
out_len = NODE_BUFFER_SIZE - UBIFS_DATA_NODE_SZ;
-+#ifdef __linux__
++#ifndef NO_NATIVE_SUPPORT
if (c->default_compr == UBIFS_COMPR_NONE &&
(flags & FS_COMPR_FL))
use_compr = UBIFS_COMPR_LZO;
@@ -131,7 +131,7 @@
if (fd == -1)
return sys_err_msg("failed to open file '%s'",
path_name);
-+#ifdef __linux__
++#ifndef NO_NATIVE_SUPPORT
if (ioctl(fd, FS_IOC_GETFLAGS, &flags) == -1)
+#endif
flags = 0;