aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mtd-utils/patches/130-lzma_jffs2.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-12-05 15:44:58 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-12-05 15:44:58 +0000
commitb48f14021170edbd22d1d8ba1b36d6ae09e4535d (patch)
treed5707964e25eade5da116b8ca84f05e95d50c430 /tools/mtd-utils/patches/130-lzma_jffs2.patch
parentaf9b8563d88739e0f5a3aab8db032bf1f4057245 (diff)
downloadmaster-187ad058-b48f14021170edbd22d1d8ba1b36d6ae09e4535d.tar.gz
master-187ad058-b48f14021170edbd22d1d8ba1b36d6ae09e4535d.tar.bz2
master-187ad058-b48f14021170edbd22d1d8ba1b36d6ae09e4535d.zip
update mtd-utils to 1.5.2
- update mtd-utils to 1.5.2 (git a494d30ab1ae40cb7665680cadf5af3ca3830a73) - remove patches that went upstream - fixes build from scratch as of broken patches Signed-off-by: Sven Roederer <devel-sven@geroedel.de> [use the final version of 1.5.2 instead, fix header of jffs2_lzma_(de,)compress()] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47790 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/mtd-utils/patches/130-lzma_jffs2.patch')
-rw-r--r--tools/mtd-utils/patches/130-lzma_jffs2.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/tools/mtd-utils/patches/130-lzma_jffs2.patch b/tools/mtd-utils/patches/130-lzma_jffs2.patch
index 17f9978bef..b04f019922 100644
--- a/tools/mtd-utils/patches/130-lzma_jffs2.patch
+++ b/tools/mtd-utils/patches/130-lzma_jffs2.patch
@@ -1,7 +1,7 @@
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,7 @@
- VERSION = 1.5.1
+ VERSION = 1.5.2
CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS)
+CPPFLAGS += -I./include/linux/lzma
@@ -123,7 +123,7 @@
+}
+
+STATIC int jffs2_lzma_compress(unsigned char *data_in, unsigned char *cpage_out,
-+ uint32_t *sourcelen, uint32_t *dstlen, void *model)
++ uint32_t *sourcelen, uint32_t *dstlen)
+{
+ SizeT compress_size = (SizeT)(*dstlen);
+ int ret;
@@ -148,7 +148,7 @@
+}
+
+STATIC int jffs2_lzma_decompress(unsigned char *data_in, unsigned char *cpage_out,
-+ uint32_t srclen, uint32_t destlen, void *model)
++ uint32_t srclen, uint32_t destlen)
+{
+ int ret;
+ SizeT dl = (SizeT)destlen;