aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mpfr
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-06 09:56:25 +0000
commitf0971cead83e1fef42c136ae539f8017401d2e2c (patch)
treeddc2576840842c3230ed61d7b684cb3e3a89d505 /tools/mpfr
parent9b2a8b53f7040c3e424a857dbc89818f3a94d1b5 (diff)
downloadmaster-187ad058-f0971cead83e1fef42c136ae539f8017401d2e2c.tar.gz
master-187ad058-f0971cead83e1fef42c136ae539f8017401d2e2c.tar.bz2
master-187ad058-f0971cead83e1fef42c136ae539f8017401d2e2c.zip
clean up gmp and mpfr
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15114 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/mpfr')
-rw-r--r--tools/mpfr/Makefile26
1 files changed, 4 insertions, 22 deletions
diff --git a/tools/mpfr/Makefile b/tools/mpfr/Makefile
index 5abb2a2c79..17734a246a 100644
--- a/tools/mpfr/Makefile
+++ b/tools/mpfr/Makefile
@@ -15,27 +15,9 @@ PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
include $(INCLUDE_DIR)/host-build.mk
-define Host/Configure
- (cd $(HOST_BUILD_DIR); \
- ./configure \
- --prefix=$(STAGING_DIR_HOST) \
- --build=$(GNU_HOST_NAME) \
- --enable-static \
- --disable-shared \
- --with-gmp=$(STAGING_DIR_HOST) \
- );
-endef
-
-define Host/Compile
- make -C $(HOST_BUILD_DIR) all
-endef
-
-define Host/Install
- make -C $(HOST_BUILD_DIR) install
-endef
-
-define Host/Clean
- rm -rf $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-gmp=$(STAGING_DIR_HOST)
$(eval $(call HostBuild))