aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mkimage
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-08 17:17:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-08 17:17:46 +0000
commitf575d6afc0e8299f9fab1db07fb1537c2e14f97c (patch)
tree53003a3e2d5c4d5e948991407b14ed211e270eea /tools/mkimage
parenta189e15a78562a477614cebcadaa1ba66752082f (diff)
downloadmaster-187ad058-f575d6afc0e8299f9fab1db07fb1537c2e14f97c.tar.gz
master-187ad058-f575d6afc0e8299f9fab1db07fb1537c2e14f97c.tar.bz2
master-187ad058-f575d6afc0e8299f9fab1db07fb1537c2e14f97c.zip
mkimage: fix spurious build errors caused by its braindead build system
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20065 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/mkimage')
-rw-r--r--tools/mkimage/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index f8d7197e13..c2cbb53a2d 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -19,6 +19,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
+ rm -f $(HOST_BUILD_DIR)/tools/.depend
touch $(HOST_BUILD_DIR)/include/config.{h,mk} $(HOST_BUILD_DIR)/include/autoconf.mk{.dep,}
$(MAKE) -C $(HOST_BUILD_DIR) SUBDIRS=tools BIN_FILES-y="mkimage" tools
endef